import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?si)\\s*<img\\b(?>(?!src=).)*?\\/>\\s*";
final String string = "<html>\n"
+ " <img src=\"someurl\" alt=\"something\" />\n"
+ " <img alt=\"something\" />\n"
+ " <img alt=\"somethingelse\"\n"
+ " att='val' />\n"
+ "<html />";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}