const regex = /(?si)\s*<img\b(?>(?!src=).)*?\/>\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?si)\\s*<img\\b(?>(?!src=).)*?\\\/>\\s*', 'g')
const str = `<html>
<img src="someurl" alt="something" />
<img alt="something" />
<img alt="somethingelse"
att='val' />
<html />`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);