# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/ul>\n?<ul>|<\\/ol>\n?<ol>)//g;t' <<< "<ul><li>
bullet
text on new line
more text
</li></ul>
<ul><li>
bullet
text on a new line
more text
</li></ul>
this should be a separate block
<li>
bullet
text on a new line
more text
</li>
this should be a separate block"