const regex = /(<\/ul>\n?<ul>|<\/ol>\n?<ol>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/ul>\\n?<ul>|<\\\/ol>\\n?<ol>)', 'g')
const str = `<ul><li>
bullet
text on new line
more text
</li></ul>
<ul><li>
bullet
text on a new line
more text
</li></ul>
this should be a separate block
<li>
bullet
text on a new line
more text
</li>
this should be a separate block`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);