using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\/ul>\n?<ul>|<\/ol>\n?<ol>)";
string substitution = @"";
string input = @"<ul><li>
bullet
text on new line
more text
</li></ul>
<ul><li>
bullet
text on a new line
more text
</li></ul>
this should be a separate block
<li>
bullet
text on a new line
more text
</li>
this should be a separate block";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}