$re = '/(<\/ul>\n?<ul>|<\/ol>\n?<ol>)/';
$str = '<ul><li>
bullet
text on new line
more text
</li></ul>
<ul><li>
bullet
text on a new line
more text
</li></ul>
this should be a separate block
<li>
bullet
text on a new line
more text
</li>
this should be a separate block';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;