package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<\/ul>\n?<ul>|<\/ol>\n?<ol>)`)
var str = `<ul><li>
bullet
text on new line
more text
</li></ul>
<ul><li>
bullet
text on a new line
more text
</li></ul>
this should be a separate block
<li>
bullet
text on a new line
more text
</li>
this should be a separate block`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}