# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<\/ul>\n?<ul>|<\/ol>\n?<ol>)"
test_str = ("<ul><li>\n"
"bullet\n"
"text on new line\n"
"more text\n"
"</li></ul>\n"
"<ul><li>\n"
"bullet\n"
"text on a new line\n"
"more text\n"
"</li></ul>\n\n"
"this should be a separate block\n\n"
"<li>\n"
"bullet\n"
"text on a new line\n"
"more text\n"
"</li>\n\n"
"this should be a separate block")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.