#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<\/ul>\n?<ul>|<\/ol>\n?<ol>)"
Local $sString = "<ul><li>" & @CRLF & _
"bullet" & @CRLF & _
"text on new line" & @CRLF & _
"more text" & @CRLF & _
"</li></ul>" & @CRLF & _
"<ul><li>" & @CRLF & _
"bullet" & @CRLF & _
"text on a new line" & @CRLF & _
"more text" & @CRLF & _
"</li></ul>" & @CRLF & _
"" & @CRLF & _
"this should be a separate block" & @CRLF & _
"" & @CRLF & _
"<li>" & @CRLF & _
"bullet" & @CRLF & _
"text on a new line" & @CRLF & _
"more text" & @CRLF & _
"</li>" & @CRLF & _
"" & @CRLF & _
"this should be a separate block"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)