import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\/ul>\\n?<ul>|<\\/ol>\\n?<ol>)";
final String string = "<ul><li>\n"
+ "bullet\n"
+ "text on new line\n"
+ "more text\n"
+ "</li></ul>\n"
+ "<ul><li>\n"
+ "bullet\n"
+ "text on a new line\n"
+ "more text\n"
+ "</li></ul>\n\n"
+ "this should be a separate block\n\n"
+ "<li>\n"
+ "bullet\n"
+ "text on a new line\n"
+ "more text\n"
+ "</li>\n\n"
+ "this should be a separate block";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}