import Foundation
let pattern = #"(<\/ul>\n?<ul>|<\/ol>\n?<ol>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<ul><li>
bullet
text on new line
more text
</li></ul>
<ul><li>
bullet
text on a new line
more text
</li></ul>
this should be a separate block
<li>
bullet
text on a new line
more text
</li>
this should be a separate block
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)