using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!00[1-9])0";
string substitution = @"2";
string input = @"0666777888
00034666777888
0034666777888
""Date"" :0";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}