use strict;
my $str = '0666777888
00034666777888
0034666777888
"Date" :0';
my $regex = qr/^(?!00[1-9])0/mp;
my $subst = '2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";