$re = '/^(?!00[1-9])0/m';
$str = '0666777888
00034666777888
0034666777888
"Date" :0';
$subst = "2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;