const regex = /^(?!00[1-9])0/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!00[1-9])0', 'gm')
const str = `0666777888
00034666777888
0034666777888
"Date" :0`;
const subst = `2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);