re = /^(?!00[1-9])0/m
str = '0666777888
00034666777888
0034666777888
"Date" :0'
subst = '2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result