import re
regex = re.compile(r"^(?!00[1-9])0", flags=re.MULTILINE)
test_str = ("0666777888\n"
"00034666777888\n"
"0034666777888\n\n"
"\"Date\" :0")
subst = "2"
result = regex.sub(subst, test_str)
if result:
print(result)