# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/x(?:\^\d+)?\+?//gm;t' <<< "8x^3-4x^2+3x-17
-6x^3+7x^2-5x+9"