// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)x(?:\^\d+)?\+?").unwrap();
let string = "8x^3-4x^2+3x-17
-6x^3+7x^2-5x+9";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}