using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"x(?:\^\d+)?\+?";
string substitution = @"";
string input = @"8x^3-4x^2+3x-17
-6x^3+7x^2-5x+9";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}