use strict;
my $str = '8x^3-4x^2+3x-17
-6x^3+7x^2-5x+9';
my $regex = qr/x(?:\^\d+)?\+?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";