re = /x(?:\^\d+)?\+?/m
str = '8x^3-4x^2+3x-17
-6x^3+7x^2-5x+9'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result