# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"x(?:\^\d+)?\+?"
test_str = ("8x^3-4x^2+3x-17\n"
"-6x^3+7x^2-5x+9")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.