#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)x(?:\^\d+)?\+?"
Local $sString = "8x^3-4x^2+3x-17" & @CRLF & _
"-6x^3+7x^2-5x+9"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)