package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)x(?:\^\d+)?\+?`)
var str = `8x^3-4x^2+3x-17
-6x^3+7x^2-5x+9`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}