$re = '/x(?:\^\d+)?\+?/m';
$str = '8x^3-4x^2+3x-17
-6x^3+7x^2-5x+9';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;