#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^.+/src/|\G([^/]+)/(?:(?=[^/]+/.*([.]))|[^/]+$)"
Local $sString = "/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)