const regex = new RegExp('^.+/src/|\\G([^/]+)/(?:(?=[^/]+/.*([.]))|[^/]+$)', 'g')
const str = `/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);