import Foundation
let pattern = #"^.+/src/|\G([^/]+)/(?:(?=[^/]+/.*([.]))|[^/]+$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)