using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+/src/|\G([^/]+)/(?:(?=[^/]+/.*([.]))|[^/]+$)";
string substitution = @"$1$2";
string input = @"/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}