re = /^.+\/src\/|\G([^\/]+)\/(?:(?=[^\/]+\/.*([.]))|[^\/]+$)/
str = '/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result