use strict;
my $str = '/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as';
my $regex = qr~^.+/src/|\G([^/]+)/(?:(?=[^/]+/.*([.]))|[^/]+$)~p;
my $subst = '$1$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";