import re
regex = re.compile(r"^.+/src/|\G([^/]+)/(?:(?=[^/]+/.*([.]))|[^/]+$)")
test_str = "/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)