$re = '~^.+/src/|\G([^/]+)/(?:(?=[^/]+/.*([.]))|[^/]+$)~';
$str = '/Users/caubry/d/[...]/src/com/[...]/folder/MyClass.as';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;