package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^\\"]*(?:\\[\w\W][^\\"]*)*"|'[^\\']*(?:\\[\w\W][^\\']*)*'|(:\w+)`)
var str = `select * from a where id = :myId3;
to_timestamp_tz(:FROM_DATE, 'YYYY-MM-DD\"T\"HH24:MI:SS')
TO_CHAR(ep.CHANGEDT,'yyyy=mm-dd hh24:mi:ss')
user input invalid string ' :shouldIgnoreThisNamedParam ' in a string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}