$re = '/"[^\\\\"]*(?:\\\\[\w\W][^\\\\"]*)*"|\'[^\\\\\']*(?:\\\\[\w\W][^\\\\\']*)*\'|(:\w+)/m';
$str = 'select * from a where id = :myId3;
to_timestamp_tz(:FROM_DATE, \'YYYY-MM-DD\\"T\\"HH24:MI:SS\')
TO_CHAR(ep.CHANGEDT,\'yyyy=mm-dd hh24:mi:ss\')
user input invalid string \' :shouldIgnoreThisNamedParam \' in a string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);