import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\\\\\"]*(?:\\\\[\\w\\W][^\\\\\"]*)*\"|'[^\\\\']*(?:\\\\[\\w\\W][^\\\\']*)*'|(:\\w+)";
final String string = "select * from a where id = :myId3;\n"
+ "to_timestamp_tz(:FROM_DATE, 'YYYY-MM-DD\\\"T\\\"HH24:MI:SS')\n"
+ "TO_CHAR(ep.CHANGEDT,'yyyy=mm-dd hh24:mi:ss')\n\n"
+ "user input invalid string ' :shouldIgnoreThisNamedParam ' in a string";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}