import re
regex = re.compile(r"\"[^\\\"]*(?:\\[\w\W][^\\\"]*)*\"|'[^\\']*(?:\\[\w\W][^\\']*)*'|(:\w+)", flags=re.MULTILINE)
test_str = ("select * from a where id = :myId3;\n"
"to_timestamp_tz(:FROM_DATE, 'YYYY-MM-DD\\\"T\\\"HH24:MI:SS')\n"
"TO_CHAR(ep.CHANGEDT,'yyyy=mm-dd hh24:mi:ss')\n\n"
"user input invalid string ' :shouldIgnoreThisNamedParam ' in a string")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")