re = /"[^\\"]*(?:\\[\w\W][^\\"]*)*"|'[^\\']*(?:\\[\w\W][^\\']*)*'|(:\w+)/m
str = 'select * from a where id = :myId3;
to_timestamp_tz(:FROM_DATE, \'YYYY-MM-DD\\"T\\"HH24:MI:SS\')
TO_CHAR(ep.CHANGEDT,\'yyyy=mm-dd hh24:mi:ss\')
user input invalid string \' :shouldIgnoreThisNamedParam \' in a string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end