// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^\\"]*(?:\\[\w\W][^\\"]*)*"|'[^\\']*(?:\\[\w\W][^\\']*)*'|(:\w+)"#).unwrap();
let string = "select * from a where id = :myId3;
to_timestamp_tz(:FROM_DATE, 'YYYY-MM-DD\\\"T\\\"HH24:MI:SS')
TO_CHAR(ep.CHANGEDT,'yyyy=mm-dd hh24:mi:ss')
user input invalid string ' :shouldIgnoreThisNamedParam ' in a string";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}