use strict;
my $str = 'select * from a where id = :myId3;
to_timestamp_tz(:FROM_DATE, \'YYYY-MM-DD\\"T\\"HH24:MI:SS\')
TO_CHAR(ep.CHANGEDT,\'yyyy=mm-dd hh24:mi:ss\')
user input invalid string \' :shouldIgnoreThisNamedParam \' in a string';
my $regex = qr/"[^\\"]*(?:\\[\w\W][^\\"]*)*"|'[^\\']*(?:\\[\w\W][^\\']*)*'|(:\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}