#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"softwareVersion\">\s([0-5].?[0-9]?+)\s\s<\/div>"
Local $sString = "<div class="content" itemprop="softwareVersion"> 2.3 </div> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")