using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""softwareVersion\"">\s([0-5].?[0-9]?+)\s\s<\/div>";
string input = @"<div class=""content"" itemprop=""softwareVersion""> 2.3 </div> ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}