const regex = /\"softwareVersion\">\s([0-5].?[0-9]?+)\s\s<\/div>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"softwareVersion\\">\\s([0-5].?[0-9]?+)\\s\\s<\\\/div>', '')
const str = `<div class="content" itemprop="softwareVersion"> 2.3 </div> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}