import re
regex = re.compile(r"\"softwareVersion\">\s([0-5].?[0-9]?+)\s\s<\/div>")
test_str = "<div class=\"content\" itemprop=\"softwareVersion\"> 2.3 </div> "
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")