package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"softwareVersion\">\s([0-5].?[0-9]?+)\s\s<\/div>`)
var str = `<div class="content" itemprop="softwareVersion"> 2.3 </div> `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}