import Foundation
let pattern = #"\"softwareVersion\">\s([0-5].?[0-9]?+)\s\s<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<div class="content" itemprop="softwareVersion"> 2.3 </div> "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}