// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"softwareVersion\">\s([0-5].?[0-9]?+)\s\s<\/div>"#).unwrap();
let string = "<div class=\"content\" itemprop=\"softwareVersion\"> 2.3 </div> ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}