re = /\"softwareVersion\">\s([0-5].?[0-9]?+)\s\s<\/div>/
str = '<div class="content" itemprop="softwareVersion"> 2.3 </div> '
# Print the match result
str.match(re) do |match|
puts match.to_s
end