$re = '/\"softwareVersion\">\s([0-5].?[0-9]?+)\s\s<\/div>/';
$str = '<div class="content" itemprop="softwareVersion"> 2.3 </div> ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);